PTA B1063 计算谱半径 C++/Python3

题目描述

在数学中,矩阵的“谱半径”是指其特征值的模集合的上确界。换言之,对于给定的 n 个复数空间的特征值 { a 1 +b 1​ i,⋯,a n +b n i },它们的模为实部与虚部的平方和的开方,而“谱半径”就是最大模。

现在给定一些复数空间的特征值,请你计算并输出这些特征值的谱半径。

输入格式

输入第一行给出正整数 N(≤ 10 000)是输入的特征值的个数。随后 N 行,每行给出 1 个特征值的实部和虚部,其间以空格分隔。注意:题目保证实部和虚部均为绝对值不超过 1000 的整数。

输出格式

在一行中输出谱半径,四舍五入保留小数点后 2 位。

样例 #1

样例输入 #1

5
0 1
2 0
-1 0
3 3
0 -3

样例输出 #1

4.24

C++

#include <bits/stdc++.h>

using namespace std;

int n;
signed main() {
    cin>>n;
    double ans=0;
//水题 不解释
    while(n--) {
        int a,b;
        cin>>a>>b;
        double temp = sqrt(a*a+b*b);
        ans=temp>ans?temp:ans;
    }
    printf("%.2f",ans);
    return 0;
}

Python3/Pypy3

import math

n = int(input())
m = 0.0
for i in range(0, n):
    lst = list(map(int, input().split()))
    m = max(math.sqrt(lst[0] * lst[0] + lst[1] * lst[1]), m)
print("%.2f" % m)

添加新评论